Monthly Archives: December 2012

Missing textures

I was asked to look at why some autogen appeared blue in dx10. This threw up another interesting dx9 vs dx10 difference. The two most common cases in which we see the light blue texture in dx10 are A) a … Continue reading

Posted in Uncategorized | 4 Comments

Progressive Taxi Part 4

I was just making the fix I described in part 3 when I stumbled across something in the shader. As I explained I had determined that the texture cords were (0,0) and so I wanted to change then to be … Continue reading

Posted in Uncategorized | 14 Comments

That Light Blue Texture

The default missing texture in DX10 is different to DX9. In DX10 a light blue texture is used whereas in DX9 its black. This is a problem chiefly because add on scenery is normally tested against DX9 and the failure … Continue reading

Posted in Uncategorized | 2 Comments

Progressive Taxi Part 3

Well pondering this it occurred to me that since the texture coords were known to be useless why not just shift them to the centre of the existing yellow triangle without changing the texture at all. So my next attempt … Continue reading

Posted in Uncategorized | 4 Comments

Progressive Taxi Part 2

If you recall when investigating this I explained that the progressive taxi arrows were drawn with the following base texture on the left.   And that when transparency was included it looked like the right – so most of the … Continue reading

Posted in Uncategorized | 3 Comments